BUG报告,请求解答

By a258852 at 2016-06-28 • 0人收藏 • 469人看过

安装完成后,点击注册,出现语法错误提示,发生在common页面第582行,求解…

14 个回复 | 最后更新于 2016-06-28
2016-06-28   #1

环境?版本?顺便报下那一行的内容?

2016-06-28   #2

apache+php5.3

2016-06-28   #3

等下,我在公司电脑上下载来模拟一遍安装啊亲,能加你QQ或者微信吗大神,感觉你以后就是中国的NO1


2016-06-28   #4

Parse error: syntax error, unexpected '[' in D:\phpStudy\WWW\common.php on line 582

2016-06-28   #5

就是上面这个错误,请问,咱们默认的安装环境是PHP那个版本呀?

2016-06-28   #6

QQ截图20160628082243.png

用PHPstudy搭配的环境,选择的默认的Apache+PHP5.3

2016-06-28   #7

个人觉得版本问题 。

具体来说:

 Filter($Item)['Content']

php手册上写:As of PHP 5.4 it is possible to array dereference the result of a function    or method call directly. Before it was only possible using a temporary    variable.  

2016-06-28   #8

己结解,环境问题,用php5.5以上版本就结决了。

2016-06-28   #9

回复 #7 @冇创意 :

正打算逐步移除5.3的支持,这个程序一开始是支持5.1的,去年才特地移除支持。

2016-06-28   #10

回复#9 @lincanbin :

5.3确实蛮老了,写起来不舒服,移除了好。

2016-06-28   #11

回复#8 @a258852 :

你的软件不是最新版的,现在PHP7都出来了,如果能用高版本的话,不要用低版本的,bug多,不安全。

2016-06-28   #12

回复 #11 @ivanilla :

而且低版本性能也菜。

2016-06-28   #13

回复#12 @lincanbin :

GitHub上 README.md 写的还是 PHP version 5.3.6 or higher. 要不要改一改?

2016-06-28   #14

回复 #0 @冇创意 :

是的,新版本是要改改了。

登录后方可回帖

登 录
信息栏
购买PHP虚拟主机 / VPS

Carbon Forum是一个基于话题的高性能轻型PHP论坛

下载地址:Carbon Forum v5.0.1
QQ群:12607708(QQ我不常上)

donate

手机支付宝扫描上方二维码可向本项目捐款

Loading...