建议程序也可以使用php5.2

By 蓝色飞人 at 2015-11-27 • 0人收藏 • 414人看过

建议再升级程序时,也可以用php5.2

13 个回复 | 最后更新于 2015-11-28
2015-11-27   #1

3.3.0的时候,Carbon Forum其实支持PHP 5.1。

后来为了淘汰PHP5.3之前的版本,我故意把一个函数换成了PHP 5.3之前版本不支持的写法。

2015-11-27   #2

回复#1 @lincanbin :

建议环境不要改变太快,支持下啊。

2015-11-27   #3

回复#2 @蓝色飞人 :

PHP 5.2第一个测试版本,是十年前发布的,当时我还在上小学,正式发布也是九年多以前。

PHP 5.2本身有很多性能、安全问题,PHP官方在很多年前就不再维护了。继续用这么旧版本的人,如果不是脑子长洞了,那就是不负责任了。

我不想有人因为用问题这么多的古老的PHP解释器,然后出问题,锅甩我程序上。并且我也想推进用户环境的升级,让用户运行在更加稳定、安全的环境上。


你说说:淘汰快十年前发布的PHP 5.2算快吗?

2015-11-27   #4

Carbon Forum可以变,但环境也变了,就得程序得升级,环境也得升级。如果环境可以的话,也可以不升级啊。

2015-11-27   #5

程序跟着环境升级太快,比较的累哈。可以在环境不变的情况下,程序继续升级。

2015-11-27   #6

回复#5 @蓝色飞人 :

那不升级Carbon Forum即可,抱着PHP都可以用十年,那么Carbon Forum 3.3.0的版本用十年又有何不可?

另外那么旧版本的PHP,如果不自己打patch,只要有被黑的价值,就是分分钟被黑。我不知道现在这种情况下,这个版本的PHP存在除了害人,还有什么用?

2015-11-27   #7

你这个帖子,让我有种

《GTA5》在我的256MiB内存的奔腾4上怎么跑不起来,建议《GTA5》支持奔腾4。

的感觉。

2015-11-27   #8

我的意思是,php5.2也可以,php5.3也可以。

2015-11-27   #9

回复#6 @lincanbin :

原来这样啊

2015-11-27   #10

回复#8 @蓝色飞人 :

实际上就是都可以,甚至5.1都可以,但是我故意让这些旧版本跑不起来。

原因参见上面。

如果想用可以去下载3.3.X的版本,反正PHP 5.2你们都用得下去呢。那3.3.X我发布到现在也才几个月肯定更加可以用了。

2015-11-27   #11

建议楼主使用php 5.1版的,不谢

2015-11-27   #12

回复#11 @adminadmin :

那就用3.6.5程序了

2015-11-28   #13

回复#8 @蓝色飞人 :

现在主流都是5.3+的了开发5.2的网站程序的估计都快没了

登录后方可回帖

登 录
信息栏
购买PHP虚拟主机 / VPS

Carbon Forum是一个基于话题的高性能轻型PHP论坛

下载地址:Carbon Forum v5.0.1
QQ群:12607708(QQ我不常上)

donate

手机支付宝扫描上方二维码可向本项目捐款

Loading...