伪静态问题...

By 炒土豆丝 at 2015-07-23 • 3人收藏 • 1351人看过

主页能打开...Apache 已开启伪静态支持,WordPress那边都没问题 _(:3ゝ∠)_

QQ截图20150722235714.png

55 个回复 | 最后更新于 2015-08-11
2015-07-23   #1

尝试打开.htaccess,去除

<IfModule mod_rewrite.c>
</IfModule>

这两行判断

2015-07-23   #2

回复#1 @lincanbin :

还是 404 _(:3ゝ∠)_

2015-07-23   #3

回复#2 @炒土豆丝 :

见鬼了,照理来说,我这个Rewrite没有写错不生效的理由吧?

RewriteRule ^register$ register.php [L]

你检查你的.htaccess里的RewriteBase看看路径对不对?

2015-07-23   #4

回复#3 @lincanbin :

这个?

QQ截图20150723002116.png

2015-07-23   #5

回复#4 @炒土豆丝 :

那删掉

ErrorDocument 404 /404.php

试试

2015-07-23   #6

回复#4 @炒土豆丝 :

你的Wordpress是不是放在安装时自动生成的、默认的www目录,而Forum是放在自己新建的vhost目录?

这样的话,我猜你可能没正确开启Apache的Rewrite。

Options all

AllowOverride all

LoadModule rewrite_module modules/mod_rewrite.so

这些在主配置文件和vhost文件中都必须保证处于开启状态。

2015-07-23   #7

回复#5 @lincanbin :

继续跪..

2015-07-23   #8

回复#6 @lincanbin :

WordPress 和 Forum 都是放在 /var/www/html/ 目录的子目录下。

Ubuntu Wiki 的 LAMP 环境默认 Web 根目录也是这个。

http://wiki.ubuntu.org.cn/Vps

2015-07-23   #9

回复#8 @炒土豆丝 :

你这个应该只对第一个vhost开启rewrite,第二个并没有开启。

cd /etc/apache2/sites-enabled
ll

查看,打开并修改Apache配置文件(实际上只要修改那个论坛的vhost配置文件就够了,可以用vi或者vim,实在不行找个图形界面的SFTP客户端改)

找到

AllowOverride None

修改为:

AllowOverride All

restart apache应该就开启rewrite了。

/etc/init.d/apache2 restart
2015-07-23   #10

回复#9 @lincanbin :

把 Apache2 的配置文件里面 四行 AllowOverride None 都改为 AllowOverride All 就好了。_(:3ゝ∠)_

话说,我的 Ubuntu + Apache2 的多域名改怎么配置呢...按照 Ubuntu WIKI 的做法在 sites-enabled 目录放了两个 txt 文件,但是不行...

QQ截图20150723112519.png

2015-07-23   #11

回复#10 @炒土豆丝 :

多域名是指一个vhost上绑定多个域名?

2015-07-23   #12

回复#11 @lincanbin :

应该是这个意思吧 _(:3ゝ∠)_

主域名当 WordPress 博客, 再弄个子域名的 bbs 建论坛...

2015-07-23   #13

回复#12 @炒土豆丝 :

我看那份帮助文档那样写没问题啊,照着做应该就行了。

你出现了什么错误?

2015-07-23   #14

回复#11 @lincanbin :

 设定了 bbs 子域名还是打不开,路径完全没问题...

2015-07-23   #15

回复#14 @炒土豆丝 :

http://httpd.apache.org/docs/2.4/vhosts/name-based.html

你参考一下这个吧,我猜是你的Apache主配置文件里没启用多vhost支持。

LoadModule vhost_alias_module modules/mod_vhost_alias.so

检查类似语句是否在httpd.conf中被注释掉了。

2015-07-23   #16

回复#14 @炒土豆丝 :

你可以试试把多个

<virtualhost *:80>  

</virtualhost>

写到同一个配置文件中

2015-07-23   #17

aaaa.jpg我遇到类似问题,服务器上修改url编码设置,解决了。

 

2015-07-23   #18

回复#16 @lincanbin :

这里 DNS 有设置出错么,vhost 配置应该成功了。

QQ截图20150723134450.png

2015-07-23   #19

回复#18 @炒土豆丝 :

DNS我测试了一下没错。

但是子域名下的Vhost出现了500错误,你打开Apache错误日志看一下就是了。

登录后方可回帖

登 录
信息栏
购买PHP虚拟主机 / VPS

Carbon Forum是一个基于话题的高性能轻型PHP论坛

下载地址:Carbon Forum v5.0.1
QQ群:12607708(QQ我不常上)

donate

手机支付宝扫描上方二维码可向本项目捐款

Loading...