安装的第一步就提示pdo_mysql未编译

By qq357914132 at 2015-05-13 • 0人收藏 • 455人看过

13154913.jpg

阿里云服务器 

5 个回复 | 最后更新于 2015-05-13
2015-05-13   #1

如同上面提示所说,你安装PHP时没有编译pdo_mysql这个模块。

这个模块是本程序用来连接数据库的更安全的数据库操作类。

PHP5.3之后默认是编译这个的,你的PHP应该是用了一些老旧的LAMP面板之类装的吧?

2015-05-13   #2

如果会用Linux,可以自己编译个pdo_mysql。

2015-05-13   #3

如果想要重新搭建LAMP环境,可以试试WDCP,不过WDCP默认使用的PHP版本也是将近十年前的旧版本。

http://www.94cb.com/t/2286

这里我又写了个教程来说明WDCP面板如何升级PHP与开启pdo_mysql。

http://www.94cb.com/t/2288

2015-05-13   #4

回复#3 @lincanbin :是WIN主机怎么破·····

2015-05-13   #5

回复#4 @qq357914132 :Windows主机最简单了。

打开php.ini,找到:

;extension=php_pdo.dll
;extension=php_pdo_mysql.dll

去掉前面的分号然后保存,重启Apache或者IIS。

登录后方可回帖

登 录
信息栏
购买PHP虚拟主机 / VPS

Carbon Forum是一个基于话题的高性能轻型PHP论坛

下载地址:Carbon Forum v5.0.1
QQ群:12607708(QQ我不常上)

donate

手机支付宝扫描上方二维码可向本项目捐款

Loading...