Intel's Appframework UI和JQuery似乎并不兼容

By lincanbin at 2015-02-01 • 0人收藏 • 649人看过

Intel's Appframework UI提供了一个插件来将Intel's Appframework替换为JQuery,如下:

http://app-framework-software.intel.com/documentation.php#afui/afui-quickstart

<script src="jquery.js"></script>
<script src="af.ui.jquery(.min).js"></script>

但是实际测试中,无论用JQuery 1或者2,都会出现类似这样的错误:

Uncaught TypeError: object is not a function jquery.js:4
m.extend.ajax jquery.js:4
Reply.$.popup.doneCallback global.js
(anonymous function) appframework.popup.js 126
m.event.dispatch jquery.js:3
r.handle jquery.js:3

QQ图片20150201141748.png

源码实在太长了,扫了好几个小时都没发现问题出在哪里,只能弃用JQuery,用Appframework了,不少地方需要调整。

1 个回复 | 最后更新于 2015-02-01
2015-02-01   #1

https://github.com/01org/appframework/issues/811

为此我跑到Appframework的Github上开了个Issue,不过遗憾的是他们并没有给出解决方案。

如果有知道怎么在Intel's Appframework UI中更换Appframework为JQuery的朋友请告诉我。

登录后方可回帖

登 录
信息栏
购买PHP虚拟主机 / VPS

Carbon Forum是一个基于话题的高性能轻型PHP论坛

下载地址:Carbon Forum v5.0.1
QQ群:12607708(QQ我不常上)

donate

手机支付宝扫描上方二维码可向本项目捐款

Loading...